Aug 15, 2009

LAB: Basic OSPF Configuration

Today, i will introduce you Basic OSPF Configuration. Topology in this lab:
Today, i will introduce you Basic OSPF Configuration. Topology in this lab:



Task 1: Perform Basic Router Configurations.
Perform basic configuration of the R1, R2, and R3 routers according to the following guidelines:
1. Configure the router hostname.
2. Disable DNS lookup.
3. Configure an EXEC mode password.
4. Configure a message-of-the-day banner.
5. Configure a password for console connections.
6. Configure a password for VTY connections.
Task 2: Configure and Activate Serial and Ethernet Addresses.
Step 1: Configure interfaces on R1, R2, and R3.
Configure the interfaces on the R1, R2, and R3 routers with the IP addresses and banwidth from the table under the Topology Diagram.
Step 2: Verify IP addressing and interfaces.
Use the show ip interface brief command to verify that the IP addressing is correct and
that the interfaces are active.
When you have finished, be sure to save the running configuration to the NVRAM of the router.
Step 3: Configure Ethernet interfaces of PC1, PC2, and PC3.
Configure the Ethernet interfaces of PC1, PC2, and PC3 with the IP addresses and default
gateways from the table under the Topology Diagram.
Step 4: Test the PC configuration by pinging the default gateway from the PC.
Task 3: Configure OSPF on the R1 Router
Task 4: Configure Authentication on out interfaces that used to exchange routing packets
I will configure R1 and other Router is similar configured.
Task1: Basic Configuration

Router>en
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#no ip domain-lookup
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#enable secret cisco
R1(config)#service password-encryption
R1(config)#banner motd #R1 is configured by THAOLV#
Task 2: Configure and Activate Serial and Ethernet Addresses.
Step 1:
R1(config)#interface Fa0/0
R1(config-if)#ip address 172.16.1.17 255.255.255.240
R1(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#interface s0/0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.252
R1(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
R1(config-if)#clock rate 64000
R1(config-if)#bandwidth 64
R1(config-if)#interface s0/0/1
R1(config-if)#ip address 192.168.10.5 255.255.255.252
R1(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down
R1(config-if)#clock rate 64000
R1(config-if)#bandwidth 256
Step 2: Verify IP addressing and interfaces
R1#show ip interface brief
Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 172.16.1.17 YES manual up up

FastEthernet0/1 unassigned YES manual administratively down down

Serial0/0/0 192.168.10.1 YES manual down down

Serial0/0/1 192.168.10.5 YES manual down down

Vlan1 unassigned YES manual administratively down down
The status of the S0/0/0 and S0/0/1 are down because it is up when there is a signal impact to it.
Step 3 and 4: You can manual configuring, i don't show here
Task 3: Configure OSPF on the R1 Router
R1(config)#router ospf 1
R1(config-router)#network 172.16.1.17 255.255.255.240 area 0
R1(config-router)#network 192.168.10.1 255.255.255.252 area 0
R1(config-router)#network 192.168.10.5 255.255.255.252 area 0
R1(config-router)#passive-interface fa0/0
Task 4: Configure authentication
I will configure authentication on the interface S0/0/0:
R1(config)#interface S0/0/0
R1(config-if)#ip ospf message-digest-key 10 md5 PASSWORD
R1(config)#router ospf 1
R1(config-router)#area 0 authentication message-digest
Done!

Author : Lâm Viết Thảo // 8:52 AM
Category:

1 comments:

  1. Excellent tutorial!!. Thank You. Exactly what I was looking for.

    ReplyDelete

Comment if you have any question. Do not spam

 
Powered by Blogger.