Aug 18, 2009

Challenge OSPF Scenario

Today, We will configure this OSPF Scenario in the figure and adding more requires
Photobucket

1. Basic Configuration on all Routers: Password, banner...

Router(config)#hostname OSIRIS
OSIRIS(config)#no ip domain-lookup
OSIRIS(config)#line console 0
OSIRIS(config-line)#password cisco
OSIRIS(config-line)#login
OSIRIS(config-line)#exit
OSIRIS(config)#username thaolv password 0 thaolv
OSIRIS(config)#line vty 0 4
OSIRIS(config-line)#login local
OSIRIS(config-line)#exit
OSIRIS(config)#enable secret cisco
OSIRIS(config)#service password-encryption
OSIRIS(config)#banner motd #OSIRIS is configured by THAOLV#

2. Configuring IP address, enable OSPF Routing, change bandwidth to fit the scenario.
On OSIRIS Router
OSIRIS(config)#interface lo0
*Mar 1 00:06:02.923: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
OSIRIS(config-if)#ip address 1.1.1.1 255.255.255.255

OSIRIS(config-if)#interface f1/0
OSIRIS(config-if)#description F1/0 is connected to ISIS
OSIRIS(config-if)#ip address 172.12.12.1 255.255.255.0
OSIRIS(config-if)#no shutdown
OSIRIS(config-if)#
*Mar 1 00:07:41.091: %LINK-3-UPDOWN: Interface FastEthernet1/0, changed state to up
*Mar 1 00:07:42.091: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to up
OSIRIS(config-if)#bandwidth 1000000
OSIRIS(config)#ip ospf authentication message-digest
OSIRIS(config-if)#ip ospf message-digest-key 1 md5 thaolv

OSIRIS(config)#interface f0/0
OSIRIS(config-if)#description F0/0 is connected to MA'AT
OSIRIS(config-if)#ip address 172.12.123.1 255.255.255.0
OSIRIS(config-if)#no shutdown
OSIRIS(config-if)#
*Mar 1 00:12:53.567: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:12:54.567: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
OSIRIS(config-if)#ip ospf authentication message-digest
OSIRIS(config-if)#ip ospf message-digest-key 1 md5 thaolv

OSIRIS(config)#router ospf 1
OSIRIS(config-router)#network 172.12.12.0 255.255.255.0 area 0
OSIRIS(config-router)#network 172.12.123.0 255.255.255.0 area 0
OSIRIS(config-router)#network 1.1.1.1 255.255.255.255 area 0
OSIRIS(config-router)#passive-interface lo0
OSIRIS(config-router)#auto-cost reference-bandwidth 1000
% OSPF: Reference bandwidth is changed.
Please ensure reference bandwidth is consistent across all routers.
OSIRIS(config-router)#

Verify by execute the command show ip route
OSIRIS#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/2] via 172.12.12.2, 00:03:08, FastEthernet1/0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/3] via 172.12.12.2, 00:03:08, FastEthernet1/0
172.12.0.0/24 is subnetted, 3 subnets
C 172.12.12.0 is directly connected, FastEthernet1/0
O 172.12.23.0 [110/2] via 172.12.12.2, 00:03:08, FastEthernet1/0
C 172.12.123.0 is directly connected, FastEthernet0/0


On ISIS Router

ISIS(config)#interface lo0
ISIS(config-if)#ip add
*Mar 1 00:17:03.263: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state
ISIS(config-if)#ip address 2.2.2.2 255.255.255.255

ISIS(config-if)#interface F1/0
ISIS(config-if)#description F1/0 is connected to OSIRIS
ISIS(config-if)#ip address 172.12.12.2 255.255.255.0
ISIS(config-if)#no shutdown
ISIS(config-if)#
*Mar 1 00:18:22.251: %LINK-3-UPDOWN: Interface FastEthernet1/0, changed state to up
*Mar 1 00:18:23.251: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to up
ISIS(config-if)#bandwidth 1000000
ISIS(config-if)#ip ospf authentication message-digest
ISIS(config-if)#ip ospf message-digest-key 1 md5 thaolv

ISIS(config)#interface F2/0
ISIS(config-if)#description F2/0 is connected to SETH
ISIS(config-if)#ip address 172.12.23.2 255.255.255.0
ISIS(config-if)#no shutdown
ISIS(config-if)#
*Mar 1 00:20:36.059: %LINK-3-UPDOWN: Interface FastEthernet2/0, changed state to up
*Mar 1 00:20:37.059: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/0, changed state to up
ISIS(config-if)#ip ospf authentication message-digest
ISIS(config-if)#ip ospf message-digest-key 1 md5 thaolv
ISIS(config-if)#bandwidth 1000000

ISIS(config)#interface F0/0
ISIS(config-if)#description F0/0 is connected to MA'AT
ISIS(config-if)#ip address 172.12.123.2 255.255.255.0
ISIS(config-if)#no shutdown
ISIS(config-if)#
*Mar 1 00:22:13.051: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:22:14.051: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
ISIS(config-if)#ip ospf authentication message-digest
ISIS(config-if)#ip ospf message-digest-key 1 md5 thaolv

ISIS(config)#router ospf 1
ISIS(config-router)#network 172.12.12.0 255.255.255.0 area 0
ISIS(config-router)#network 172.12.123.0 255.255.255.0 area 0
*Mar 1 00:23:37.751: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on FastEthernet1/0 from LOADING to FULL, Loading Done
ISIS(config-router)#network
*Mar 1 00:23:42.131: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
% Incomplete command.

ISIS(config-router)#network 172.12.23.0 255.255.255.0 area 0
ISIS(config-router)#network 2.2.2.2 255.255.255.255 area 0
ISIS(config-router)#passive-interface lo0
ISIS(config-router)#auto-cost refe
ISIS(config-router)#auto-cost reference-bandwidth 1000
% OSPF: Reference bandwidth is changed.
Please ensure reference bandwidth is consistent across all routers.

Verify by execute the command show ip route
ISIS#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/2] via 172.12.12.1, 00:03:57, FastEthernet1/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/2] via 172.12.23.3, 00:03:57, FastEthernet2/0
172.12.0.0/24 is subnetted, 3 subnets
C 172.12.12.0 is directly connected, FastEthernet1/0
C 172.12.23.0 is directly connected, FastEthernet2/0
C 172.12.123.0 is directly connected, FastEthernet0/0



On SETH Router

SETH(config)#interface lo0
SETH(config-if)#
*Mar 1 00:25:16.795: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
SETH(config-if)#ip address 3.3.3.3 255.255.255.255

SETH(config-if)#interface F1/0
SETH(config-if)#description F1/0 is connected to ISIS
SETH(config-if)#ip address 172.12.23.3 255.255.255.0
SETH(config-if)#no shut
SETH(config-if)#
*Mar 1 00:26:06.383: %LINK-3-UPDOWN: Interface FastEthernet1/0, changed state to up
*Mar 1 00:26:07.383: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to up
SETH(config-if)#bandwidth 1000000
SETH(config-if)#ip ospf authentication message-digest
SETH(config-if)#ip ospf message-digest-key 1 md5 thaolv

SETH(config-if)#interface F0/0
SETH(config-if)#description F0/0 is connected to MA'AT
SETH(config-if)#ip address 172.12.123.3 255.255.255.0
SETH(config-if)#no shut
SETH(config-if)#
*Mar 1 00:27:21.883: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:27:22.883: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
SETH(config-if)#ip ospf authentication message-digest
SETH(config-if)#ip ospf message-digest-key 1 md5 thaolv
SETH(config-if)#exit

SETH(config)#router ospf 1
SETH(config-router)#network 172.12.123.0 255.255.255.0 area 0
SETH(config-router)#network 172.12
*Mar 1 00:28:39.975: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on FastEthernet0/0 from LOADING to FULL, Loading Done.23.0 2
*Mar 1 00:28:41.887: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done55
% Incomplete command.

SETH(config-router)#network 172.12.23.0 255.255.255.0 area 0
SETH(config-router)#network 3.3.3.3 255.25
*Mar 1 00:28:57.647: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on FastEthernet1/0 from LOADING to FULL, Loading Done5.255
% Incomplete command.

SETH(config-router)#network 3.3.3.3 255.255.255.255 area 0
SETH(config-router)#passive-interface lo0
SETH(config-router)#auto-cost re
SETH(config-router)#auto-cost reference-bandwidth 1000
% OSPF: Reference bandwidth is changed.
Please ensure reference bandwidth is consistent across all routers.

Verify by execute the command show ip route
SETH#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/3] via 172.12.23.2, 00:00:21, FastEthernet1/0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/2] via 172.12.23.2, 00:00:21, FastEthernet1/0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
172.12.0.0/24 is subnetted, 3 subnets
O 172.12.12.0 [110/2] via 172.12.23.2, 00:00:21, FastEthernet1/0
C 172.12.23.0 is directly connected, FastEthernet1/0
C 172.12.123.0 is directly connected, FastEthernet0/0

Note: To show neighbor to view DR ad BDR you can execute the command show ip ospf neighbor
ISIS#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
3.3.3.3 1 FULL/BDR 00:00:38 172.12.23.3 FastEthernet2/0
1.1.1.1 1 FULL/DR 00:00:36 172.12.123.1 FastEthernet0/0
3.3.3.3 1 FULL/DROTHER 00:00:31 172.12.123.3 FastEthernet0/0
1.1.1.1 1 FULL/DR 00:00:31 172.12.12.1 FastEthernet1/0

You see OSIRIS Router appear as DR because i configure begin with OSIRIS Router. To know why you can view previous post
Determining DR and BDR in OSPF Router .To change DR and BDR you can shutdown lo0 interface on OSIRIS Router and return by no shutdown command. Next you execute the command clear ip ospf process on any Router.
You can verify authentication in OSPF by execute the command show ip ospf interface
OSIRIS#show ip ospf interface F1/0
FastEthernet1/0 is up, line protocol is up
Internet Address 172.12.12.1/24, Area 0
Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 1.1.1.1, Interface address 172.12.12.1
Backup Designated router (ID) 2.2.2.2, Interface address 172.12.12.2
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:05
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 2.2.2.2 (Backup Designated Router)
Suppress hello for 0 neighbor(s)
Message digest authentication enabled
Youngest key id is 1

Any Question is welcome here.

Author : Lâm Viết Thảo // 4:14 PM
Category:

0 comments:

Post a Comment

Comment if you have any question. Do not spam

 
Powered by Blogger.